Wireless Routers

TP-Link AC1900 Wireless Dual Band Gigabit VDSL/ADSL Modem Router for Phone Line Connections

Ships from UAE
Price on request

Send a free RFQ and get the supplier's best price.

Min Order1
ConditionNew
WarrantyYES
Country of shippingUAE
Save Share

Request for quotation

Free · No obligation · Supplier replies on WhatsApp

Trade with confidence on Abraa

Safe and secure payments using Abraa safe trade systems

Learn more

Supplier verification not completed

Pay only through Abraa to stay protected. Never pay a supplier by direct transfer.

Learn more

Secure Payment

Pay through Abraa, never by direct transfer to a supplier.

Product Inspection

Book a check before shipping to confirm quality and quantity.

Buyer Protection

Get support and refunds if goods arrive not as described.

Verified Suppliers

Licence, address and on-site checks by the Abraa team.

Product Specification

Condition New
Warranty YES
Wireless Data Rates 1900 Mbps
Frequency Dual Band
Wireless Adapter Included No
Antenna Dual Band Antenna
Interface Others

Product Descriptions

TP-LINK AC 1900. Wi-Fi band: Dual-band (2.4 GHz / 5 GHz), Top Wi-Fi standard: IEEE 802.11ac, Wi-Fi standards: IEEE 802.11a,IEEE 802.11ac,IEEE 802.11b,IEEE 802.11g,IEEE 802.11n. Ethernet LAN interface type: Gigabit Ethernet, Ethernet LAN data rates: 10,100,1000 Mbit/s, Cabling technology: 10/100/1000Base-T(X). Networking standards: IEEE 802.11a,IEEE 802.11ac,IEEE 802.11b,IEEE 802.11g,IEEE 802.11n,IEEE 802.3,IEEE 802.3ab,IEEE..., Data link protocols: IPv4, IPv6, Management protocols: SSL for TR-069, SNMP v1/2c. Supported network protocols: ATM Forum UNI3.1/4.0, PPP over ATM (RFC 2364), PPP over Ethernet (RFC2516), IPoA (RFC1577/2225),.... Antenna type: External, Antenna connector type: RP-SMA
No Feedbacks yet.
Please login to review this product.
close image\
Product Added To Container Successfuly !
An error occured while adding the product
please try again later !
You can't order less than 1
Welcome to Abraa !
Subscribe now to receive the Abraa Newsletter with latest products, best offers and current deals directly to your email !
Loading…